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Welcome

The Board members and the staff of the

Princeton Health Department welcome you to
the Princeton Board of Health and thank you for Public Health

Prevent. Promote. Protect.

your service to our community. Princeton Health Department

This document serves as your orientation to the structures and processes of Princeton
government, the Princeton Health Department, and the Board of Health.

Please ensure that you do the following:

1) Read this document in its entirety. Many of the sections also contain links to additional docu-
ments that are important to review. The links are indicated with blue text for ease of reading.

2) Ask questions! If you have any questions about these documents or your role as a Board of
Health member, please do not hesitate to let us know by calling or e-mailing Jeff Grosser,
Health Officer at 609-497-7610 or jgrosser@princetonnj.gov

3) This packet, and other important documents related to the Board of Health, can always be
found on the Princeton Health Department webpage.


mailto:jgrosser@princetonnj.gov
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Princeton, NJ

Princeton covers an area of 18.1 square miles in the heart of central New Jersey. It is composed of the
former Township of Princeton and Borough of Princeton which consolidated effective January, 2013 and is
now known as Princeton. The population of Princeton is approximately 30,000.

A substantial portion of the property of Princeton University lies within the borders of Princeton as does
the property of the Institute for Advanced Study. Other well-known educational institutions within
Princeton are the Hun School, the Princeton Day School, and the Stuart Country Day School of the Sacred
Heart.

While no major arteries directly touch Princeton, it is dissected by US Highway Route 206; and there is
ready access to US Highway Route 1, the New Jersey Turnpike, the Garden State Parkway and Amtrak and
New Jersey Transit which provide direct rail services to New York and Philadelphia.

In general, Princeton is an open semi-wooded community of diverse housing, including substantial and
moderate homes and a highly recognized affordable housing program and is an example of sound
suburban development. There is also one shopping center, several other shopping areas of smaller size,
some office research and services areas and a large amount of preserved open space.

If you’re new to Princeton, please visit this page to find out what services are available.



http://www.princetonnj.gov/department-locator.html

Section 3:
Health Department

Structure &

Operations

Public Health



Public Health

Prevent. Promote. Protect.

Princeton Health Department

Princeton Health Department
2016 Organizational Chart

Mayor Liz Lempert
Town Council

Board of Health
Joann Hill
George DiFerdinando, MD, MPH
Linda Steiner-Sichel
Rick Weiss, MS
Steven Miller, PhD
Lauren Babcock-Dunning, MPH
Linda Schwimmer, |D
Mona Shah, PhD
Meredith Hodach-Avalos, MD

Heather Howard, |D, Council Liaison

Health Officer
Jeffrey C. Grosser, MHS, HO, REHS

Sr. REHS
Randy Carter

REHS
Keith Levine

egistrar of Vital Statistics

Lauralyn Bowen

eputy Registrar of Vital
Statistics

Tamara Kretschmann

Public Health Nurse
Kathy Korwin

Animal Control Officer
Rabies Control
Nate Barson

Health Educator
Devangi Patel

Child Health Conferences

Dr. Anjali Sharma

Updated: 08/2016


Presenter
Presentation Notes
Animated vertical organization chart
(Intermediate)


Tip: The instructions below describe how to reproduce the exact organization chart and animation effects in the example above. In the animation procedures, the number of animation effects that require modification in the Animation Pane will vary if the chart contains a different number of managers and employees.


To reproduce the SmartArt effects on this slide, do the following:
On the Home tab, in the Slides group, click Layout, and then click Blank. 
On the Insert tab, in the Illustrations group, click SmartArt. In the Choose a SmartArt Graphic dialog box, in the left pane, click Hierarchy. In the Hierarchy pane, click Organization Chart (first row, first option from the left), and then click OK to insert the graphic into the slide. 
Select the graphic, and then click one of the arrows on the left border. In the Type your text here dialog box, in the text box for the first-level rectangle, enter Director (or the name of the director). In the second-level rectangle enter Assistant Director (or the name of the assistant director). In the text boxes for the third-level rectangles, enter Manager 1, Manager 2, and Manager 3 (or the names of the managers). 
On the slide, do the following to add more employee rectangles:
Right-click the Manager 1 rectangle, point to Add Shape, and then click Add Shape Below. Repeat this process one more time for a total of three rectangles below Manager 1. 
Right-click the Manager 2 rectangle, point to Add Shape, and then click Add Shape Below.
Right-click the Manager 3 rectangle, point to Add Shape, and then click Add Shape Below.  
Select the graphic, and then click one of the arrows on the left border. In the Type your text here dialog box, in the text boxes for the fourth-level rectangles, enter Employee (or the names of the employees).
If you would like to modify the number of directors, managers, and employees in the chart to match the structure of your organization, do one or more of the following: 
To add a rectangle within a particular level, right-click one of the rectangles in that level, point to Add Shape, and then click Add Shape After or Add Shape Before. 
To add a rectangle below another rectangle, right-click the higher-level rectangle, point to Add Shape, and then click Add Shape Below. 
To delete a rectangle, select the rectangle and then press DELETE. 
To add text to new rectangles, select the graphic, and then click one of the arrows on the left border. In the Type your text here dialog box, enter text.  
Select the graphic. Under SmartArt Tools, on the Format tab, click Size, and then do the following:
In the Height box, enter 6.55”.
In the Width box, enter 8.79”. 
Under SmartArt Tools, on the Format tab, click Arrange, click Align, and then do the following:
Click Align to Slide.
Click Align Middle. 
Click Align Center. 


To reproduce the effects for the employee rectangles on this slide, do the following:
Press and hold SHIFT, and then select all of the rectangles in the slide. On one of the rectangles, on the middle of the left edge, drag the blue square adjustment handle slightly to the left to increase the width of all of the rectangles. 
On the slide, select the graphic. On the Home tab, in the Font group, select Gill Sans MT from the Font list, and then select 20 from the Font Size list.
Press and hold SHIFT, and then select all of the rectangles in the graphic. On the Home tab, in the bottom right corner of the Drawing group, click the Format Shape dialog box launcher. In the Format Shape dialog box, click Line Color in the left pane. In the Line Color pane, select No line. 
Also in the Format Shape dialog box, click Shadow in the left pane. In the Shadow pane, click the button next to Presets , and then under Outer click Offset Center (second row, second option from the left). 
Also in the Format Shape dialog box, click 3-D Format in the left pane, and then do the following in the 3-D Format pane under Bevel:
Click the button next to Top, and then click Cool Slant (first row, fourth option from the left). 
Next to Top, in the Width box, enter 5 pt, and in the Height box, enter 5 pt.
Press and hold SHIFT, and then select all of the employee rectangles in the graphic. On the Home tab, in the bottom right corner of the Drawing group, click the Format Shape dialog box launcher. In the Format Shape dialog box, click Fill in the left pane, select Gradient fill in the Fill pane, and then do the following:
In the Type list, select Linear.
Click the button next to Direction, and then click Linear Down (first row, second option from the left).
Under Gradient stops, click Add gradient stop or Remove gradient stop until two stops appear in the slider.
Also under Gradient stops, customize the gradient stops as follows:
Select the first stop in the slider, and then do the following:
In the Position box, enter 0%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Darker 50% (sixth row, fifth option from the left). 
Select the last stop in the slider, and then do the following: 
In the Position box, enter 100%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Darker 25% (fifth row, fifth option from the left). 


To reproduce the effects for the manager rectangles on this slide, do the following:
Press and hold SHIFT, and then select all three manager rectangles in the graphic. On the Home tab, in the bottom right corner of the Drawing group, click the Format Shape dialog box launcher. In the Format Shape dialog box, click Fill in the left pane, select Gradient fill in the Fill pane, and then do the following:
In the Type list, select Linear.
Click the button next to Direction, and then click Linear Down (first row, second option from the left).
Under Gradient stops, click Add gradient stop or Remove gradient stop until two stops appear in the slider. 
Also under Gradient stops, customize the gradient stops as follows:
Select the first stop in the slider, and then do the following:
In the Position box, enter 0%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Darker 25% (fifth row, fifth option from the left). 
Select the last stop in the slider, and then do the following: 
In the Position box, enter 100%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Lighter 40% (fourth row, fifth option from the left). 


To reproduce the effects for the director rectangles on this slide, do the following:
Press and hold SHIFT, and then the director and assistant director rectangles (first- and second-level rectangles) in the graphic. On the Home tab, in the bottom right corner of the Drawing group, click the Format Shape dialog box launcher. In the Format Shape dialog box, click Fill in the left pane, select Gradient fill in the Fill pane, and then do the following:
In the Type list, select Linear.
Click the button next to Direction, and then click Linear Down (first row, second option from the left).
Under Gradient stops, click Add gradient stop or Remove gradient stop until two stops appear in the slider.
Also under Gradient stops, customize the gradient stops as follows:
Select the first stop in the slider, and then do the following:
In the Position box, enter 0%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Lighter 40% (fourth row, fifth option from the left). 
Select the last stop in the slider, and then do the following: 
In the Position box, enter 100%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Lighter 60% (third row, fifth option from the left). 
Press and hold SHIFT, and then select the director and assistant director rectangles in the graphic. On the Home tab, in the Font group, click the button next to Font Color, and then click Dark Blue, Text 2 (first row, fourth option from the left).


To reproduce the connecting line between Manager 2 and the last employee under Manager 1, do the following:
On the Insert tab, in the Illustrations group, click Shapes, and then under Lines click Freeform (11th option from the left). On the slide, do the following to draw a freeform line:
Click the first point on the right edge of the bottom employee rectangle. 
Click the second point approximately 0.5” to the right of the first point.
Click the third point approximately 3.5” above the second point. 
Double-click the fourth point on the left edge of the Manager 2 rectangle to finish the freeform line. 
On the slide, select the freeform line. On the Home tab, in the bottom right corner of the Drawing group, click the Format Shape dialog box launcher. In the Format Shape dialog box, in the left pane, click Line Color. In the Line Color pane, select Solid line, click the button next to Color, and then under Theme Colors click Blue, Accent 1 (first row, fifth option from the left). 
Also in the Format Shape dialog box, in the left pane, click Line Style, and then do the following in the Line Style pane:
In the Width box, enter 2 pt. 
In the Dash type list, select Round Dot (second option from the top).
In the Cap type list, select Round. 
In the Join type list, select Round.


To reproduce the animation effects on this slide, do the following:
On the slide, select the graphic. On the Animations tab, in the Advanced Animation group, click add Animation, and then click More Entrance Effects. In the Add Entrance Effect dialog box, under Basic, click Peek In, and then click OK. 
Also on the Animations tab, in the Timing group, in the Duration box, enter 0.50.
Also on the Animations tab, in the Animation group, click Effect Options, and then click Level One by One.
Also on the Animations tab, in the Advanced Animation group, click Animation Pane.
In the Animation Pane, click the double arrow under the animation effect to expand the contents of the list of effects.
Also in the Animation Pane, select the first animation effect (peek-in effect). On the Animations tab, in the Timing group, in the Start list, select With Previous.
In the Animation Pane, press and hold CTRL, and then select the second, fourth, sixth, eighth, 10th, 12th, 14th, 16th, and 18th animation effects (peek-in effects). On the Animations tab, in the Animation group, click More, and then under Entrance click Fade.
Also on the Animation tab, in the Timing group, in the Duration box, enter 0.50 seconds.
In the Animation Pane, select the third animation effect (peek-in effect). On the Animations tab, in the Animation group, click Effect Options, and then click From Right.
In the Animation Pane, press and hold CTRL, and then select the fifth, seventh, and ninth animation effects (peek-in effects). On the Animations tab, in the Animation group, click Effect Options, and then click From Top.
In the Animation Pane, press and hold CTRL, and then select the 11th, 13th, and 15th animation effects. On the Animations tab, in the Animation group, click Effect Options, and then click From Left.
In the Animation Pane, press and hold CTRL, and then select the 11th, 12th, 13th, 14th, and 15th effects. On the Animations tab, in the Timing group, in the Start list, select With Previous.
In the Animation Pane, press and hold CTRL, and then select the 17th and 19th animation effects (peek-in effects). On the Animations tab, in the Timing group, in the Start list, select With Previous.
Also on the Animations tab, in the Animation group, click Effect Option, and then click From Left. 
On the slide, select the freeform line. On the Animations tab, in the Advanced Animation group, click Add Animation, and then under Entrance click Wipe.
In the Animation Pane, select the 20th animation effect (wipe effect). On the Animations tab, in the Timing group, do the following:
In the Start list, select After Previous.
In the Duration box, enter 0.50 seconds.
Also on the Animations tab, in the Animation group, click Effect Options, and then click From Bottom.
In the Animation Pane, drag the 20th animation effect until it is 15th in the list of effects. 


To reproduce the background on this slide, do the following:
Right-click the slide background area, and then click Format Background. In the Format Background dialog box, click Fill in the left pane, select Gradient fill in the Fill pane, and then do the following:
In the Type list, select Linear.
Click the button next to Direction, and then click Linear Down (first row, second option from the left)
Under Gradient stops, click Add gradient stop or Remove gradient stop until three stops appear in the slider.
Also under Gradient stops, customize the gradient stops as follows:
Select the first stop in the slider, and then do the following:
In the Position box, enter 0%.
Click the button next to Color, and then under Theme Colors click Black, Text 1 (first row, second option from the left). 
Select the next stop in the slider, and then do the following: 
In the Position box, enter 32%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Darker 50% (sixth row, fourth option from the left).
Select the last stop in the slider, and then do the following: 
In the Position box, enter 100%.
Click the button next to Color, and then under Theme Colors click Blue, Accent 1, Lighter 80% (second row, fifth option from the left).



Video Overview of Public Health in Princeton

Princeton Health Department Video - Summer 2015
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https://www.youtube.com/watch?v=cIN8TzD6jpY

Princeton Health Department

Mission: To preserve, promote and improve the health and well-being of the people, animals and environment of
Princeton
Vision: Leading the way to a healthy Princeton

Values
ompassion: Treat one another and those we serve with empathy and kindness.
ntegrity: Hold our responsibilities to the community of Princeton in the highest regard.
edication: Stay focused on the cause and purpose of our work.
ollaboration/Partnership: Work collaboratively with our community partners, sharing knowledge and resources to enhance
ccess to services and improve the health and well-being of all residents in Princeton.
nowledge: Strive to be the best in our field by keeping up to date with the various interdisciplinary areas we cover.

Essential Services
o Monitor health status to identify community problems, needs and assets
« Diagnose and investigate health problems and health hazards in the community

« Link people to needed personal health services and assure provision of health

| | ! Evaluate WMopitor '%z.
care, health education, and outreach services, especially to vulnerable .

. Assure
populations Competent M
. g Workforce o™ ." & Investigate
« Inform and educate people about health issues s _. O
- . . . . Link Researsti] Ifonmy I
o Mobilize community partnerships and action to address community health needs R o/ Provide Edcate, g
Care EMPEOWER
« Develop policies and plans that advocate for and support individual and community ! Sobifize &
Enforce Co. )
health efforts Laws p":,f:,f:ﬁ;p, \J
Develop J,P’
« Assure an expert public health workforce Folicles )
. . . . 0
« Evaluate effectiveness, accessibility, and quality of health services & Lﬂa\“

» Research for new insights and innovative solutions to health problems
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Environmental Health Services

Environmental Health is responsible for protection of public health through the following programs:

Inspection Services Septic Systems, Wells, and Water Other Services

o Restaurants Testing « Lead Poisoning Prevention

« Childcare Centers « Septic Systems « Property Information Search
« Schools « Wells « Public Water Supply Referral
« Swimming Pools « Water Testing « Well Water & Health

« Street Festivals and Temporary Food Stands
« Mobile Food Units (Food Trucks)

Staff also offers education in every area Environmental health also consults or
of coverage. Registered Environmental collaborates in the following efforts:
Health Specialists perform an annual * Publicwater supplies

refresher to food service workers in o Watersheds protection and preservation
Princeton ¢ Sanitation at community facilities

e Environmental contaminants incidents
e (chemical spills, groundwater contamination, etc.)

¢ Natural and man-made disaster response

¢ Air quality information and monitoring



Public Health Nursing & Communicable Disease Services

Public health nursing and communicable disease services are responsible for the investigation of
outbreaks of communicable diseases, surveillance of reportable diseases and provision of educational
materials and services to assist communities in reducing the incidence of communicable disease.

Public Health Nurse: Public Health Nurses (PHNs) investigate reported diseases and, as appropriate,
involve epidemiologists, environmental health specialists, the public health
laboratory, or the health officer in their investigations. They conduct interviews,
provide health education, refer for further care and treatment, and take measures to

] prevent further spread of the disease.
Core Functions:

1. Assessing and identifying populations at risk;

2. Providing outreach and case finding using population-based services;

3. Using systematic, relevant data collection from public health nursing practice for community health assessment;

4. Using case information and epidemiological methods to link epidemiology and a clinical understanding of health and iliness;
5. Developing and implementing health guidance, counseling, and educational plans using the established nursing process;

6. Providing health plans to assure health promotion efforts that include primary clinical prevention and early intervention strategies;
7. Using the nursing process and triage to determine priorities for interventions and services based on risk assessment and
community needs especially for underserved populations;

8. Advocating policies and funding that create clinical programs and improve health status;

9. Establishing procedures and processes which ensure competent implementation of prevention measures and treatment
schedules;

10. Providing clinical preventive services, including clinical screenings and preventive

care;

11. Facilitating access to care through the use of nursing assessment, referral for risk reduction, prevention, restorative, and
rehabilitative services, and the establishing clinical programs and services;

12. Participating in all components of communicable disease prevention and control, including clinical surveillance, case
identification, and treatment;

13. Planning, developing, and initiating interdisciplinary nursing plans for care and case management;

14. Establishing and maintaining written procedures and protocols for clinical care; and

15. Identifying, defining, coordinating, and evaluating enhanced clinical services for complex populations and special risk
groups.



Health Promotion & Education Services

Health Promotion and Education Services is a multi-disciplinary team of health professionals who educate, facilitate,
advocate and collaborate to motivate all members of the Orange County community to achieve safe and healthy lifestyles.

"The focus of health education is on people and action. In general, its aims are to encourage people to adopt and sustain
healthful life patterns, to use judiciously and wisely the health services available to them, and to make their own decisions,
both individually and collectively, to improve their health status and environment." -- World Health Organization

Common Roles and Responsibilities: Pl
e Assessment and data collection Commurity

e Communication of health information (cultural values, norms)
e Community engagement and collaboration Schools

e Counseling and consultation jefiviea (A SnL /Ettios)
e Liaison to task force and coalitions Interpersonal

(sacial network)

e Media facilitation
e Program planning and evaluation »

e Resource development and grant writing :I:nilut:f:gﬂ
e Social marketing attitude, skills)
o Staff development and training

The Socioecologic Framework, which illustrates the
many levels on which Princeton Health Department works
to improve health.



Vital Records and Statistics Services

Vital records and statistics services consist of two NJ Certified Registrars of Vital Statistics that record birth, death,
marriage and civil unions for the municipality.

Vital Statistics records have been kept in Princeton since 1903. Vital Statistics is the recording of all Births, Deaths,
Marriages, and Civil Unions that occur within a municipality. All Vital Statistics are also recorded to the State to provide
data on morbidity and mortality.

Additional Responsibilities:

*Marriage licenses and certificates
*Birth certificates
eDeath certificates
Civil union licenses and certificates
*|ssuing burial permits
*Disinterment permits
*Transit permits
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Board of Health Member Responsibilities

The Board of Health is the primary policy-making, rule-making and adjudicatory body for the health department and is charged to
protect and promote the public health of Princeton

This function may include allocating resources, planning programs, and advising the Health Officer on health needs.

Responsibilities of board members can be divided into three primary categories: Administrative Work, Advocacy, Policy Develop-
ment. These duties may include, but are not limited to any of the following.

Administrative Work of the Board

e Attend meetings of the Board of Health regularly and promptly.

e Serve on Board Committees or as a representative of the Board of Health to other bodies, such as the Human Services
Commission Princeton.

e Review all meeting materials in advance of meetings and complete assigned work between meetings.

e Participate fully in open, constructive dialogue regarding local public health both in and out of meetings. Ask critical questions;
seek clarity and im- plications of decisions before voting.

e Evaluate the performance of the health officer on an annual basis.

e Attend health department sponsored community activities or special events as requested.

Advocacy
e Serve as a Board liaison to designated organizations of importance to the board as requested.
e Represent a broad cross-section of the community to the board.

e Represent public health to the community.

e Speak for the board only when delegated to do so by the board.

e Stand behind decisions of the board and Health Officer.

e Inform other policy-makers and the community of the needs of the health department in its mission to protect and promote the
public’s health.

Policy Development

e Educate yourself on your community, its public health status, and its needs. Communicate issues, trends, or other relevant
information to the board and the health director.

e Present need for new policies as Board member becomes aware of need from serving on other community groups.

e Carefully examine all new policies for community-wide implications and discuss issues and concerns openly in Board meetings.




Board of Health Policy and Procedure Manual

Board of Health policies and procedures can be found in the

Princeton Boards, Commissions, Committees (BCC) Handbook. It
is reviewed annually by the Mayor and governing body of PRINCETON BOARD OF HEALTH
ORIENTATION PACKET

Princeton and distributed to all members in January. 2016

In addition to the BCC handbook, upon being appointed to the
Board of Health members will also receive a Princeton Board of
Health Orientation packet that includes a welcome letter from

the Health Officer and “Effective Boards of Health” document,

authored in collaboration between the National Association of
Local Boards of Health and the New Jersey Local Boards of

Health. Said document highlights roles and responsibilities of a
Public Heal

Prevent. Promote . Protect

Princeton Health Department

Board of Health member in New Jersey as well as provides an
overview of how meetings operate and what services should

be provided by the Health Department.



Board of Health
Strategic Plan

Based on the health priorities identified in the Community Health Assessment, the Princeton Board of
Health identifies priority areas to work on through policies and programs. Though the Community Health
Assessment is completed only every three to five years, the BOH Strategic Plan is updated every two years.

The 2015 strategic plan focused on three priority areas: Healthy and Safe Community Environments, Public
Health Continuous Improvements, and Prepare for Public Health Emerging Threats. It was developed
through a participatory process that includes research on effective programs and policies, staff and
community expertise, and available resources . Each priority includes objectives and specific action steps.

Board members oversee and provide input on the work of the plan through involvement in at least one of
the priority area subcommittees. The implementation and evaluation of the plan is supported by health
department staff, community stakeholders, and other municipal departments.

The full plan is located on the Publications and Reports section of the PHD website



http://www.princetonnj.gov/health/publications/Strategic-Plan-Princeton-Health-Department-2015-2020.pdf

BOARD OF HEALTH ROSTER

NAME EMAIL FIELD APPOINTED TERM EXPIRATION
George DiFerdinando, MD, MPH diferdge@sph.Rutgers.edu | Epidemiology/Health 12/31/2015 12/18/2018
Chairperson Policy
Linda Steiner-Sichel Linda Sichel@yahoo.com Nursing 1/1/2015 12/31/2017
Vice-Chariperson
JoAnn Hill joannbry@Verizon.net Infectious Disease 1/1/2015 12/31/2017
Secretary
Steven Miller, PhD msteverino@aol.com Environmental Science 12/31/2015 12/18/2018
Rick Weiss, MS Weiss@viocare.com Health Technology 1/1/2014 12/31/2016
Lauren Babcock-Dunning, MPH laurencbd@gmail.com Biostatistics 12/31/2015 12/31/2017
Alternate No. 1
Linda Schwimmer, JD Linda.Schwimmer@gmail.com | Health Policy 12/31/2015 12/18/2018
Mona Shah, PhD mona77@gmail.com Epidemiology 12/31/2015 12/31/2017
Meredith Hodach-Avalos, MD mhavalos@gmail.com General Medicine 7/2016 12/31/2016
Heather Howard, JD Heatherhoward@yahoo.com| Health Policy 1/1/2016 12/31/2016

Council Liasion



mailto:diferdge@sph.Rutgers.edu
mailto:Linda_Sichel@yahoo.com
mailto:joannbry@Verizon.net
mailto:msteverino@aol.com
mailto:Weiss@viocare.com
mailto:laurencbd@gmail.com
mailto:Linda.Schwimmer@gmail.com
mailto:mona77@gmail.com
mailto:mhavalos@gmail.com
mailto:Heatherhoward@yahoo.com

Princeton Board of Health
Commiittees 2016
Member Assignments

Committee Member

Budget & Finance / Personnel George DiFerdinando
Linda Steiner-Sichel

Planning Linda Schwimmer
Steve Miller
Mona Shah

Liaison Roles

Joann Hill Princeton Alcohol and Drug Alliance (PADA)

Linda Steiner-Sichel

George DiFerdinando Princeton Environmental Commission
Steve Miller



Board of Health Meetings

The Princeton Board of Health meets each month of the year, except August. All meetings are held on the

third Tuesday of the meeting months at Monument Hall, One Monument Drive in Princeton, unless noted
otherwise.

The week before each meeting, you will receive monthly health reports for the Board via e-mail. It will contain
the agenda for the next week’s meeting and any materials related to the agenda item that should be reviewed

in advance.

Meeting agendas contain a variety of items, including educational sessions, reports on Health Department
programs or activities, or review of state and local laws and regulations.

2016 Meeting Schedule Location:

January 18, 2016
February 16, 2016
March 15, 2016
April 19, 2016
May 17, 2016
June 21, 2016
July 19, 2016
September 20, 2016
October 18, 2016
November 15, 2016
December 20, 2016

Monument Hall

One Monument Drive

Princeton, NJ 08540

East Conference Room

Time:
7:30 p.m

Contact Person:
Jeff Grosser, Health Officer
609-497-7610

jgrosser@princetonnj.gov



mailto:jgrosser@princetonnj.gov
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